Задачи 39, 46. Проверим, является ли данная транспортная задача закрытой

  • ID: 29015 
  • 4 страницы

Фрагмент работы:

Задачи 39, 46. Проверим, является ли данная транспортная задача за…

Задача 39.

Проверим, является ли данная транспортная задача закрытой:

и.........

Следовательно, данная транспортная задача закрытая. Найдем исходное решение по методу минимального тарифа.

Склады потребители запасы

100 12 15 20 14 100 18 200

14 90 8 15 60 11 20 150

20 15 80 25 60 12 10 19 150

потребление 100 90 80 120 110 500

Число занятых клеток в таблице равно..., в нашем примере заполненных клеток оказалось 7, то есть условие невырожденности выполнено. Полученное исходное решение запишем в виде матрицы

Стоимость перевозки при исходном решении составляет:

Проверим найденное решение на оптимальность. Добавим в распределительную таблицу столбец...и строку.... Полагая..., найдем остальные... и....

1 2 3 4 5...

100 90 80 120 110

1 200 100 12 15 20 14 100 18 0

2 150 14 90 8 15 60 11 20 0

+ ?

3 150 20 15 80 25 60 12 10 19 1

? +

12 8 24 11 18

Вычислим оценки свободных клеток:

Получили оценки... и..., следовательно, исходное решение не является оптимальным и его можно улучшить.

Выполним перераспределение груза (перераспределение показано стрелочками). Получим новый опорный план.

1 2 3 4 5...

100 90 80 120 110

1 200 100 12 15 20 14 100 18 0

+ ?

2 150 14 90 8 60 15 11 20 ?9

3 150 20 15 20 25 120 12 10 19 1

? +

12 17 24 11 18

Стоимость перевозки составляет:

Проверим найденное решение на оптимальность.

Проверим условия оптимальности для незаполненных клеток:

Получили оценки...... и..., следовательно, исходное решение не является оптимальным и его можно улучшить.

Выполним перераспределение груза. Получим новый опорный план.

1 2 3 4 5...

100 90 80 120 110

1 200 100 12 15 20 20 14 80 18 0

2 150 14 90 8 60 15 11 20 ?5

3 150 20 15 25 120 12 30 19 1

12 13 20 11 18

Проверим условия оптимальности для незаполненных клеток:

Условия оптимальности выполнены для всех клеток. Следовательно, построенный план оптимален.

Ответ:......

Задача 46.

Составить экономико-математическую модель. Найти решение задачи линейного программирования при помощи средств Excel на ПК.

Имеющийся фонд материалов М1, М2, М3 нужно распределить между изготовителями продукции П1, П2, П3, П4 так, чтобы получить максимальную прибыль. Нормы расходов материалов, запасы и прибыль, получаемая за единицу продукции, приведены в таблице.

Материал Фонд материалов Продукция

П1 П2 П3 П4

М1 50000 0,7 0,9 1,5 2,3

М2 28000 1,4 0,3 0,7 2,5

М3 40000 0,5 2,1 1,8 0,7

Прибыль 5 7 6 9

Решение:

Пусть x1, x2, x3, x4 - количество продукции вида П1, П2, П3 и П4 соответственно. Очевидно, что x1?0, x2?0, x3?0, x4?0.Составим ограничения по каждому виду материалов:

М1: 0,7x1+0,9x2+1,5x3+2,3x4?50000

М2: 1,4x1+0,3x2+0,7x3+2,5x4?28000

М3: 0,5x1+2,1x2+1,8x3+0,7x4?40000

Требование максимизации прибыли:

=...

Требуется найти x1, x2, x3, x4, максимизирующие целевую функцию и удовлетворяющую указанным ограничениям, т.е. решить задачу линейного программирования:

=...

Решим эту задачу с помощью Excel.

Вводим в ячейки таблицы исходные данные:

A B C D E F G

1 0,7 0,9 1,5 2,3 0 50000

2 1,4 0,3 0,7 2,5 0 28000

3 0,5 2,1 1,8 0,7 0 40000

4 5 7 6 9

5

6 x1 x2 x3 x4 f

7 0 0 0 0 0

8

9

10

В ячейках E1-E3 и E7 введены формулы.

E1: =СУММПРОИЗВ(A1:D1;A7:D7)

E2: =СУММПРОИЗВ(A2:D2;A7:D7)

E3: =СУММПРОИЗВ(A3:D3;A7:D7)

E7: =СУММПРОИЗВ(A7:D7;A7:D7)

Затем даем команду Сервис/Поиск решения:

Задаем следующие параметры:

в поле "Установить целевую ячейку": $E$7

максимальное значение

в поле "Изменяя ячейки": $A$7:$D$7

Далее задаем ограничения:

$A$7:$D$7?0

$E$1:$E$3?$F$1:$F$3

Затем нажимаем на кнопку "Выполнить".

Получаем ответ: x1=0, x2=15952,38, x3=0, x4=9285,71, fmax=195238,1 (ден. ед.)